Pages

Wednesday, March 18, 2009

My LEGO Network

*rant-on*

Okay... One of the members of GFLUG is big into My LEGO Network (or MLN for short). It's a social network filled with games, quests, building friends & objects, trading objects, etc. aimed at kids (the GFLUG member has a 9 year old son). So I tried it out. It's Flash based. It's cool. But under Safari on my iMac, it runs soo ssslllooowww; almost to the point of being unusable. When you're doing a quest and have to click in several places to build objects, or flip from building objects to trading them with Networkers... It's just painful!

And another thing I find annoying? The LEGO Universe Creation Lab... where people take a building challenge, then show off their creations. Flipping through creations 9 at a time, with so much extra Flash crap on the page just makes it painful to paginate through!

Don't get me wrong, I love Flash and can see some of the potential benefits of it. But LEGO get a fraking UI designer to help out with your web-site pages. Either find a way to optimize your pages or replace some of the Flash with JavaScript. Bottom line, thinking about he people using your web-site & make them want to keep coming back to it, not making them die from a slow page load!

*rant-off*

...I return you to your normal LEGO broadcast & I'm sorry for the interruption...

4 comments:

James Wadsworth said...

Over use of flash is a problem I see on almost every "large" website. Disney, Star Wars, and others all seem to base their sites off of flash. Its awful.

brickbuilder711 said...

Is it me? I never liked MLN, barely used it. Facebook is a million times better, and just as good as Facebook is any forum or blog to interact with.

Tolga

brickbuilder711 said...

Oops, I guess you mentioned someone else, with the 9 yr old son. I have one anyway. Great idea, but not too interactive.

Tolga

Sinjin said...

Well, it's true... sometimes I think the by definition, social networking sites have to be full of spammy, badly done, slow loading programming, most of which is also useless!
Then again, I did switch to the Flock browser to try and speed things up a bit...